10

Sketch 3.3 Update Bugs

5 years ago from , Web Designer

Updated to Sketch 3.3 yesterday and have been experiencing some very serious problems.

  1. Placed images render blank in the comp. If I place a picture, save the file and reopen it, some images appear blank, or white. The image file is still there, I can resize it and move it, but the box image is white. (see a video demonstration of this attached below)

https://www.dropbox.com/s/cicx6jgqh1opttz/problem%201.mov?dl=0

  1. Text changes occasionally when nudged or when new items (images, other text ect.) are pasted in the same folder or nearby. I couldn't recreate this to show here but it has happened maybe 10 times in the last 48 hrs. I will update here when it happens next.

I just wanted to post to see if Bohemian Coding is aware of this and if they are working on something. I tweeted them yesterday but have yet to receive a reply.

23 comments

  • J AJ A, 5 years ago

    Sent them feedback about the images rendering blank. They responded and said they were looking into it. If enough people message them about it I'm sure they'll bump up the urgency level. Pretty big bug

    7 points
  • Patrick WongPatrick Wong, 5 years ago

    I think holding ALT and pressing an arrow key to nudge something .1px should be an optional setting. I want holding down ALT and using the arrow key to nudge an object 1px, like how the previous release worked.

    In my workflow I typically hold down ALT to see distance from the edge of the artboard or other objects, and then use the arrows to nudge in 1px increments. Now, I have to hold ALT to see the distance, let go of ALT, nudge 1px values, then hold ALT again.

    4 points
  • Cory GibbonsCory Gibbons, 5 years ago

    I'm experiencing the text changing on nudge as well, it's really frustrating. Copy pasting the group and deleting the original seems to fix it.

    3 points
    • Phil SPhil S, 5 years ago

      Same here, reported this via the in app reporter a couple of weeks ago, the guys seem to be aware of it (issue #16211)

      It was hard to reproduce but happened quite often. Enabling click-through for the groups and only then moving/resizing them "fixed" the issue.

      1 point
      • John LeschinskiJohn Leschinski, 5 years ago

        Where do you find their bug tracking?

        0 points
        • Phil SPhil S, 5 years ago

          https://bohemiancoding.zendesk.com/home

          If this looks curiously empty it's because of the peculiar way they use issue tracking on zendesk–whenever I submitted a bug they usually close the ticket with their first reply, even if the bug is not fixed yet.

          Might be a smart move as a public zendesk tracker must be a pain to moderate. Also not sure how productive it would be to have dozens of open and public issues in there with a "looking into it" status.

          I trust they solve the bugs we report ...in private, so to say. Which does make it rather frustrating to report bugs, because basically you only find out if something you reported was actually fixed if it's mentioned in the release notes of a potential next update.

          0 points
  • Michael MMichael M, 5 years ago

    I also HIGHLY recommend joining their official Facebook group and posting issues like that there.

    https://www.facebook.com/groups/sketchformac/

    2 points
  • Seb JachecSeb Jachec, 5 years ago

    Have you reported these bugs via the in-app feedback reporter?

    2 points
  • Petr VlkPetr Vlk, 5 years ago (edited 5 years ago )

    also subpixel shadows (ie 0.5px when you are designing for retina displays at @1x) are broken in 3.3 :(

    1 point
  • Arjun PenemetsaArjun Penemetsa, 5 years ago

    Oh man..I've just spent 20 mins trying to figure this out (blank images).. I tried to revert to previous versions, move it to different layers/artboards. I just thought I made a mistake. Also, didnt have a backup copy so had to go back to the source for screenshots to paste.. Thanks for pointing out that this is a bug.

    1 point
  • John McDowallJohn McDowall, 5 years ago

    Seems like something you should email them directly about.

    1 point
  • John LeschinskiJohn Leschinski, 5 years ago

    Seems like a big deal.

    1 point
  • Vishu SinghVishu Singh, 5 years ago

    The first bug (blank images) has just ruined my several hours worth of work.

    I spent a lot of effort transforming multiple images to create a cover flow effect and when I reopened the file now they're ALL GONE! All of them rendering as blank rectangles. This is insane!

    0 points
  • Christian Krammer, 5 years ago

    Text resizing bug also happens for some time now, as I used the beta for the last couple of weeks. I reported this bug already a while ago but Bohemian said I'm the only one who encounters it. Well, not quite ...

    So they are already aware of it and I just send the a note again. But it would be great if you also could report this bug with the in-app report tool: Help > Custom Support. Then they know that there's a real problem here.

    0 points
  • Jesse HeadJesse Head, 5 years ago

    When exporting, unless I choose my 'Documents' directory as the destination, the file won't export. So say for example I want to export to my desktop... after pressing export it appears to save but yet doesn't appear there. SUPER annoying.

    Filed a bug report but no response.

    0 points
  • Gilbert BagaoisanGilbert Bagaoisan, 5 years ago

    I'm having the nudge bug issue, too! Very frustrating.

    0 points
  • Josh LeeJosh Lee, 5 years ago

    text size nudge is the worst.

    0 points
  • Mahdi FarraMahdi Farra, 5 years ago

    I haven't had the first problem, but I had the second one a million times today.

    Also sometimes the text size changes dramatically when clicking on other layers!

    ps: in your article both points have the same number "1.".

    0 points
  • Chris Welch, 5 years ago

    I'm running into the text nudging issue as well and have been for the last two months of using Sketch. By far the most frustrating bug. Some transparency into acknowledging some of these issues would be nice.

    0 points
  • Matthew SaforrianMatthew Saforrian, 5 years ago

    I've run into these issues too. Another minor one is that rearranging colors in the global colors panel sometimes doesn't work correctly.

    0 points